Shameless Pic Thread.... - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 11-20-2006, 05:37 PM
DBeasst
Guest
 
Posts: n/a
Talking

Well I finally got a few pics taken of the FW. Thought I'd post them.. well.. just because. [img]smile.gif[/img]

A friend of mine gave me this idea for tags:


I had the old purple and damaged tint removed. Here is the new 35% tint installed.

And Friday after lunch, this happened:


Thank you, we now return to our regularly scheduled forums.....
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 11-20-2006, 05:41 PM
effin-newbee
Guest
 
Posts: n/a
Post

Nice pics! [img]smile.gif[/img]
post #3 of 10 (permalink) Old 11-20-2006, 05:42 PM
N0DIH
Guest
 
Posts: n/a
Post

I'll double your 100K and add 7K more....

Looks like ride I parked next to last night! Cool!
 
post #4 of 10 (permalink) Old 11-21-2006, 07:09 AM
yellowtaws6
Guest
 
Posts: n/a
Post

Very nice car and awesome plates!

We need to have a Virginia Fleetwood GTG since there are 4 of us on the board from Virginia!
post #5 of 10 (permalink) Old 11-21-2006, 07:13 AM
toomanytoyz
Guest
 
Posts: n/a
Post

Hey Mike, your door is ajar. (no, it's a DOOR!) Ba dum bump.

Looks great. Love the plates!

My MASSOL plates are coming in the mail. (say it out loud )
post #6 of 10 (permalink) Old 11-21-2006, 07:22 AM
eracer
Guest
 
Posts: n/a
Post

I just turned 100 too [img]tongue.gif[/img]
post #7 of 10 (permalink) Old 11-21-2006, 08:14 AM
DBeasst
Guest
 
Posts: n/a
Post

Thanks for the complements. He's a work in progress, but then it seems all of my cars are. [img]tongue.gif[/img]

RamAirRocket, I got ya beat. Roadmonster has 236K!

96Fleetwood, that'd be cool. I love cruising with this car! Give me an excuse to head coast-ward. Another WAIL'er has a FW too, I've only seen it once though.

toomanytoyz, No more YEHAA huh? And your sense of humor is as twisted as mine. [img]tongue.gif[/img]
post #8 of 10 (permalink) Old 11-21-2006, 11:38 AM
N0DIH
Guest
 
Posts: n/a
Post

Cool, I am racking them up fast, I run around 33K to 36K a year. I'll roll 207K tomorrow. Every 10 days is another 1000 miles... Minimum...

How has reliability been? Mine has been fantastic. Just done brakes, tires, fix and exhaust clamp, drag link, oil, oil filter and air filter changes and that is really about all I have had to do in the past 56K miles since I have had the car.

Quote:
Originally posted by DBeaSSt:
Thanks for the complements. He's a work in progress, but then it seems all of my cars are. [img]tongue.gif[/img]

RamAirRocket, I got ya beat. Roadmonster has 236K!

96Fleetwood, that'd be cool. I love cruising with this car! Give me an excuse to head coast-ward. Another WAIL'er has a FW too, I've only seen it once though.

toomanytoyz, No more YEHAA huh? And your sense of humor is as twisted as mine. [img]tongue.gif[/img]
post #9 of 10 (permalink) Old 11-21-2006, 12:24 PM
DBeasst
Guest
 
Posts: n/a
Post

Quote:
Originally posted by RamAirRocket:
How has reliability been? Mine has been fantastic. Just done brakes, tires, fix and exhaust clamp, drag link, oil, oil filter and air filter changes and that is really about all I have had to do in the past 56K miles since I have had the car.
Great actually. I bought it in 04 with 180K. The ONLY time it's given me problems is when the fuel pump went out this spring. Other that that I've only put maintenance stuff into it. Tuneup, brakes, etc. Now having said that, it's on tranny #2 which was installed somewhere around 170Kish by the previous owner, who is on the Forums here.

Car has been to NY and back (WagonFest06) to NC and back twice and all over VA.

Oh, on another note. I had an oil sample analyzed recently. Engine shows very little wear, even for one of it's age!

Counting on the FW to be just as reliable!
Mike
post #10 of 10 (permalink) Old 11-21-2006, 04:11 PM
BCs71
Guest
 
Posts: n/a
Post

Mine turned 100K earlier this past summer on the drive over to the drag strip. [img]graemlins/.gif[/img] Thought that was somehow fitting that my first trip to the track and beat on it was the same time it "rolled over".
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome