Trunk pull down motor issue - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 10-28-2014, 08:13 PM Thread Starter
Senior Member
 
sprocket's Avatar
 
Join Date: Jul 2007
Location: Delray Beach, FL
Posts: 3,693
 
Trunk pull down motor issue

my motor went up when I opened the trunk. But when I latch it, it doesn't pull it down... Sad

When I got the car the motor was disconnected and broken. I sourced one from the JY from an 82K Caddy and it worked fine for the last 2 months.
Saturday I used the trunk no issue. Later in the afternoon I put my bag in there and it wouldn't close. I was about 70 miles from home and figured, it was latched although not 'seated', so after 3 or 4 tries I got in and drove. I stopped 2 miles away for a drink and when I got out it was closed.

I proceeded on my way and when I got home, opened it to get my bag out. It worked fine.
This morning I opened it and placed an item in and it closed fine. After work tonight, I opened it and it wouldn't close again.

Okay at least I'm home....I still had the broken one so I figured I'd just swap it back in until I could figure it out.
I had a crap day at work and was hurrying in the dying light.....and I plugged it in....So now the broken one extended. I tried closing that one but it's broken and wouldn't pull down.

I know I have voltage as the old one extended.

I don't know if the one I have in there is bad or if there is an issue with the reverse voltage to pull it down.....

I treied taking the broken one apart to manually lower it to no avail...... FSM was not helpful Sad

Luckily it won't rain tonight so even though it's latched it's still partially open.

Other note: Tonight the trunk ajar light was on while I was driving. Don't recall if it came on or not on Saturday....

sprocket is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 10-28-2014, 11:05 PM
Senior Member
 
4501 Safari's Avatar
 
Join Date: Jun 2004
Location: Jacksonville, FL
Posts: 860
 
Arrow Here you go...

Order AC Delco part 16629927 and your trunk pull down will be happy. I went through hell to get the pull down in the '96 FLT to work but that was because the PO cut the wiring harness at the plug(!) rather than take the damn trunk light bulb out so the trunk could stay open at shows...

There is, of course, volumes out there on the Cadillac forums about why the pull down won't work and how to fix it but, unless your motor gear box is cracked, it's this switch. FYI, the switch is NOT in the trunk lid.

Good luck,

Richard Snipes
4501 Safari in Jax, FL

So many projects, so little time, so little money...jist hope ta improve..
4501 Safari is offline  
post #3 of 6 (permalink) Old 10-29-2014, 03:05 PM
Member
 
vanaisa's Avatar
 
Join Date: Sep 2005
Location: Estonia
Posts: 91
 
Garage
Send a message via Skype™ to vanaisa
easy fix - do not afraid to open switch (located near pulldown motor, on same bracket) - just drill rivets off, open and clean contacts inside, reassembly with screws.
vanaisa is offline  
 
post #4 of 6 (permalink) Old 10-29-2014, 08:49 PM Thread Starter
Senior Member
 
sprocket's Avatar
 
Join Date: Jul 2007
Location: Delray Beach, FL
Posts: 3,693
 
Quote:
Originally Posted by vanaisa View Post
easy fix - do not afraid to open switch (located near pulldown motor, on same bracket) - just drill rivets off, open and clean contacts inside, reassembly with screws.
thanks guys. I manually wound down the broken one, and will explore the other....
sprocket is offline  
post #5 of 6 (permalink) Old 01-12-2015, 01:46 PM
Senior Member
 
Join Date: Mar 2005
Posts: 942
 
I just "deleted" the pull-down mechanism on mine. No regrets

1995 Cadillac Fleetwood Brougham BBB - Build in progress
Caddylack is offline  
post #6 of 6 (permalink) Old 01-13-2015, 07:29 AM
Senior Member
 
Join Date: Jan 2001
Location: St. Louis
Posts: 7,636
 
Quote:
Originally Posted by vanaisa View Post
easy fix - ....
Thanks. Had bought a new switch many years back, followed by a new motor just 2 years ago. Had the same mystery problem as sprocket a few months ago, but only one time and never since. I used to wind the storage net around the pulldown, - thought that may have been involved.

Good to know the repair fix.

\'96SS SOB: SSRI, Herter Tune, Tri-Y II, , 3000 Edge, F/HO bars, METCO extendeds with CV MMC, Bilsteins, currently Vredestein Ultrac Sessanta (315/35 rear). Finally, wait for it... LT-4 knock module!
\'96FWB BUW-Butt Ugly White: PCMPerformance tune, HDFA w/ swissed filter, 1/2 SLP s.s. catback with H- and Flow Super 50s, oem opti rebuilt 3 times, SS Bars, METCO LCA, Airlift 1000, Monroe SS, PowerTrax No-Slip, CTS wheels with +1 rubber. Finally, yes again... LT-4 knock module!
96 Black is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome