1994 fleetwood transmission computer? - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 01-24-2017, 04:47 PM Thread Starter
Senior Member
 
95DoubleBubble's Avatar
 
Join Date: Jul 2011
Location: brooklyn, MD
Posts: 677
 
1994 fleetwood transmission computer?

So a little over a week ago I got in the car to go to work and noticed the car was pulling away really slow from stops, which was weird because it ran fine the night before. I went through the climate diagnostic and got a code 84, looked it up and it said
"Transmission 3-2 control solenoid circuit" Made the mistake of going to Aamco first who tried to tell me it needed a full rebuild. Took it to a friend of my step dad who put new shift solenoids in and informed me there wasn't even a speck of metal in the pan. After test driving it it still does it, he said its probably a computer issue but I'm not sure if its the main computer or one of the body control modules. Has anyone else had to fix this problem before?

Big Phil, certified lowrider-aholic

http://s55.photobucket.com/albums/g134/lowriderphil/
95DoubleBubble is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 01-24-2017, 05:11 PM
Senior Member
 
babywag's Avatar
 
Join Date: Mar 2016
Location: California
Posts: 975
 
1 pcm controls engine & trans.

Could easily be a wiring problem. If all that was replaced was the solenoids was any of the wiring checked?

I could scan the service manual pages for code 84 later today and post if interested?
babywag is offline  
post #3 of 5 (permalink) Old 01-24-2017, 05:35 PM Thread Starter
Senior Member
 
95DoubleBubble's Avatar
 
Join Date: Jul 2011
Location: brooklyn, MD
Posts: 677
 
Quote:
Originally Posted by babywag View Post
1 pcm controls engine & trans.

Could easily be a wiring problem. If all that was replaced was the solenoids was any of the wiring checked?

I could scan the service manual pages for code 84 later today and post if interested?
he said he replaced the solenoids and checked the wires while they were under the car and all looked good. Car is at his shop so I can't check but I have been browsing topics and saw something about an emi fuse. I found an online service that can sell me a pcm flashed to my vin number for around $160. Its just weird how fast the problem started, literally drove home fine at 2am and when I went to work at 4pm it started acting up.

Big Phil, certified lowrider-aholic

http://s55.photobucket.com/albums/g134/lowriderphil/
95DoubleBubble is offline  
 
post #4 of 5 (permalink) Old 01-24-2017, 05:52 PM
Senior Member
 
babywag's Avatar
 
Join Date: Mar 2016
Location: California
Posts: 975
 
Harness is cheap $30, if going through trouble of dropping pan and replacing solenoids I would have had trans. harness replaced as well.

pcms rarely go bad, 99% it's wiring.
$160 is pretty steep IMHO...
I have a spare pcm in the garage I'd be willing to sell cheaper.

I'd find somebody with a Tech1 or similar that can test it correctly before throwing another $160 @ it.

Just my .02
babywag is offline  
post #5 of 5 (permalink) Old 01-28-2017, 07:00 PM Thread Starter
Senior Member
 
95DoubleBubble's Avatar
 
Join Date: Jul 2011
Location: brooklyn, MD
Posts: 677
 
Finally back on the road, new ecu did the trick, I guess a plus is I now have new shift solenoids in the transmission.
95DoubleBubble is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome