Power for DVD player/screens/ect... - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 05-25-2003, 07:31 AM
sydneyssnowflake
Guest
 
Posts: n/a
Post

Okay, I've got my sunvisor screen installed already. I just used the power lead that was already there for the lights on the vanity mirror, and grounded it under one of the mounting screws for the visor. Anyone forsee any problems with that? Next - my DVD player. I've got a Blazer center console that I'm going to mount it in. Where should I pull power for that? Also, I have installed a 5.6" screen in my Blazer overhead console (haven't installed the console yet though). Where to pull power for it? It looks as though I'm not meant to have headrest screens - so no install questions about that. First set of 5" screens I buy have no don cable with them, and it is a discontinued model, so I'm about screwed. Then I bought a pair of 5.6" screens and they won't play color! Both set were bought of eBay - so I'm trying to get refunds worked out - but that's another story! I just need to know where to pull power for a screen and DVD player. Thanks!
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 05-25-2003, 10:09 AM
Southern Comfort
Guest
 
Posts: n/a
Post

You basically have three wires-red, black, and yellow. The red should be ran to a constant power source, the best place would be the fuse panel or tap into your radio power. The black is common sense- ground. The yellow wire should be ran to a power source that should have power when the key is turned forward. Another thing would be to tap into the yellow wire for you radio also. That way when you turn your car off the dvd and screens turn off also. You dont want to put the yellow wire on a constant power unless you want a dead battery.

BTW- Send me a pic and info about your the monitors that you dont have cables for.
post #3 of 7 (permalink) Old 05-25-2003, 10:32 AM
sydneyssnowflake
Guest
 
Posts: n/a
Post

Talk about timing! I just emailed you not 5 minutes ago. On the power leads, I mainly just wanted to make sure that if I tapped into the power for my radio that it wouldn't overload it. Now, maybe you can help me out with the DIN cables I need. I emailed you with the info about them, but here it is again - they are Emerson MT1000 5" headrest screens. Maybe you can also tell me why the Pyle 5.6" monitors I got only play black and white even with a video amplifier. Thanks!
 
post #4 of 7 (permalink) Old 05-25-2003, 11:53 AM
Southern Comfort
Guest
 
Posts: n/a
Post

After doing research for pictures of your monitors. I must say that you are a very LUCKY lady. I take it that yours look like my headrest monitors. That monitor along with many other monitors are generic made. Meaning one company makes them and sends them to various companies like TRC, Accell, Emerson, Mobile Vision, etc. I can get the cable and control box that you need for them. It is an inexpensive part but I wont be able to get a price until Tues or Wed. How much did you pay for these monitors?

As for your other monitors I dont know anything to tell you on those.
post #5 of 7 (permalink) Old 05-25-2003, 12:31 PM
sydneyssnowflake
Guest
 
Posts: n/a
Post

Thanks!!!! Yeah, they look very similar to your headrest screens. I bought them off eBay (http://cgi.ebay.com/ws/eBayISAPI.dll...tem=3017746356) and paid like $130 for both of them shipped. If you are able to get me the DIN cables for them, then I won't need the 5.6" screens anyway. The Emerson 5" screens would fit better in my headrests anyway. Maybe my luck is turning around after all!
post #6 of 7 (permalink) Old 05-25-2003, 12:41 PM
Southern Comfort
Guest
 
Posts: n/a
Post

Do the other monitors have a switch on them labeled NTSC/PAL? If so try switching it over that may do it for you.
post #7 of 7 (permalink) Old 05-25-2003, 02:10 PM
sydneyssnowflake
Guest
 
Posts: n/a
Post

Unfortunately they don't. The 5.6" screens are Pyle PLVWHR56M. Maybe someone out there knows a secret to getting them to work right. I just can't understand both of them being defective??? I'll be totally happy if I can just get the cables for the Emerson monitors. Thanks for the suggestion though.
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome