96 floor shifter issue - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-26-2015, 08:21 PM Thread Starter
Junior Member
 
Join Date: Oct 2011
Location: Germany
Posts: 14
 
96 floor shifter issue

Had a 95 column in temporarily from the junk yard due to a break in. All was good. Got the new column and floor shifter in now my OD doesn't work. Reacts as if it's in nuetral. You feel nothing catch as you shift into OD and if you press gas it just revs. D and all others work fine. Could cable be hooked up incorrectly? Installer claims he had to make a new bracket as mine wasn't fitting. Do you think this is the issue? I have relocated my vehicle to NY and can't take it back to the shop that did the work. Any help would be highly appreciated
Chevy Ridah is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-27-2015, 06:42 AM
Senior Member
 
4DoorSS's Avatar
 
Join Date: Nov 2008
Location: Beautiful Chester County, PA
Posts: 7,974
 
Quote:
Originally Posted by Chevy Ridah View Post
Had a 95 column in temporarily from the junk yard due to a break in. All was good. Got the new column and floor shifter in now my OD doesn't work. Reacts as if it's in nuetral. You feel nothing catch as you shift into OD and if you press gas it just revs. D and all others work fine. Could cable be hooked up incorrectly? Installer claims he had to make a new bracket as mine wasn't fitting. Do you think this is the issue? I have relocated my vehicle to NY and can't take it back to the shop that did the work. Any help would be highly appreciated
What is the car that you're working on? My assumption based on what I read is this is a True 96 Impala with Floor Shift setup. Not sure with what you described as to why the "Installer" had to make a new Bracket but this could be your issue.

To me, it does sound like a linkage (Shifter, cable or bracket) problem not allowing the trans to shift correctly. I would first get to basics and get under the car, disconnect the Linkage at the trans lever and make sure that the trans shifts into all gears manually. Start with it in Neutral and then by hand turn the lever thru each selection.... Click (OD), Click (D), Click (2) and Click (1). If all looks good there, check and adjust the linkage from the shifter cable and have someone in the car go through each gear til you can determine why it wont engage into OD. Its probably just something simple that you need to be able to see while looking at it.

================================================== =============


'95 Caprice SS conversion - Bonny Buckets - 96 Column, Shifter and Console - 3.73 Gear and Herter tune - Z/28 Cluster - Blazer OH Console - Green/Pink bushings - Chromed Impala Wheels - Eibach Springs and Bilstein Shocks - Corvette Engine Dress - the list goes on and still more to do...it never ends.
4DoorSS is offline  
post #3 of 3 (permalink) Old 10-27-2015, 08:25 AM Thread Starter
Junior Member
 
Join Date: Oct 2011
Location: Germany
Posts: 14
 
OK will be home in 2 weeks and try what you said thanks a million. Did some more research and found out a buddy that did some work here in alabama on my car had removed a bracket off my trans for some apparent reason that he felt wasnt allowing my trans to perform at maximum levels, now I'm ticked. Therefore the shop that put my floor shifter back in made a custom bracket because a piece was missing. I will find out the name of the exact piece. So at least I'm getting there somewhat.
Chevy Ridah is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome