Window motor and regulator - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 09-05-2016, 09:52 PM Thread Starter
Member
 
chillrobb's Avatar
 
Join Date: Feb 2016
Posts: 90
 
Question Window motor and regulator

My front driver side window motor went bad. I purchased a new AC Delco motor from Rock Auto. It was a pain in the butt to pull everything out, but I accomplished it. I replaced the motor and was able to bolt the regulator and everything in place. The spring in the regulator fell out, I was debating whether I should take a picture of it, and I decided not to. I think I put that spring back in correctly; I read another post about making sure that doesn't fall out and having to rewind the spring. I did not do such a thing, I just placed it back in a way that seemed logical. And everything seems to work just fine, with one exception. There is a pin that pops out on the motor itself, right where the gear is. I didn't compare this pin to the old part, but it is causing problems for me. If I roll the window down completely, then try to roll it up, it gets jammed up. I found that one of the arms of the regulator is not clearing that pin on the motor, I have to push the window in (through the door with the panel off) to get the window to roll up. My first thought is that I installed something incorrectly, but I don't think that is the case. I reluctantly am going to take it all back apart on my next day off. I am afraid I may need to cut off part of that pin. But I feel I shouldn't have to. I was curious if anyone here has run into a similar issue. Oh and this is a Roadmaster by the way.
chillrobb is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 09-05-2016, 10:02 PM
Senior Member
 
4x4high's Avatar
 
Join Date: Jan 2012
Location: Fremont, Ca.
Posts: 1,621
 
Garage
Send a message via Yahoo to 4x4high
You will need to tension the spring otherwise the motor itself won't lift the heavy window. Not sure on what pin you speak of but if you take a pic once you get it back apart i'm sure someone can help you out.

1996 DGGM Impala SS
4x4high is offline  
post #3 of 10 (permalink) Old 09-05-2016, 10:23 PM Thread Starter
Member
 
chillrobb's Avatar
 
Join Date: Feb 2016
Posts: 90
 
I think you are wrong about the spring. My issue with the spring was making sure I put it back with the proper orientation. I don't know what you guys are talking about having to put tension on it, it works fine. My issue is the regulator binding up. Here is a pic of the pin in question.
chillrobb is offline  
 
post #4 of 10 (permalink) Old 09-06-2016, 09:51 AM
Senior Member
 
Fred Kiehl's Avatar
 
Join Date: Feb 2009
Location: Largo, FL 33774
Posts: 10,870
 
That pin is the outer shaft that fits in the frame, and runs against the frame as a bearing to control the pinion gear against the sector gear. It should not move.

1991 OCC 461 (.030 over 454) BBC, 3.23 posi, flash to pass, drop spindles & springs, Impala rims, Hydroboost, Recaros, MOMO/wood SW w/QR, custom wood shift knob, Pioneer DEH P77DH
1992 OCC now with 5.7 tbi, DEH P77DH
For a parts list, check https://www.impalassforum.com/vBulle...ion-parts.html
Fred Kiehl is offline  
post #5 of 10 (permalink) Old 09-06-2016, 01:17 PM Thread Starter
Member
 
chillrobb's Avatar
 
Join Date: Feb 2016
Posts: 90
 
Cool Motor

Quote:
Originally Posted by Fred Kiehl View Post
That pin is the outer shaft that fits in the frame, and runs against the frame as a bearing to control the pinion gear against the sector gear. It should not move.
This makes sense, the pin acting as a bearing. And by frame I am assuming you are referring to the regulator assembly. Now my problem is one of the arms of the frame catches on this pin when the window is moving up. I have to roll the window almost all of the way down, no problems there, but when rolling up, the frame gets stuck on that pin. The pin protrudes beyond the frame, including the sector gear, by at least one half of an inch. My first thought is that I assembled it back wrong, but I can't figure out how I could have done that; with the exception of that spring, but I am confident I placed that back correctly. I didn't break anything either, that's a win in my book. I am going to take it all apart again, hopefully without breaking anything, and compare the motors. I am thinking I might have to cut off part of that pin with my Dremel. I don't understand why I would have to modify anything, this is manufactured by the OEM. I was just curious if any one has ever encountered this same issue. Oh, as a side note I found another window motor in my junk pile, so apparently I have done this repair before but do not remember. What a pain in the butt this is!
chillrobb is offline  
post #6 of 10 (permalink) Old 09-06-2016, 01:19 PM Thread Starter
Member
 
chillrobb's Avatar
 
Join Date: Feb 2016
Posts: 90
 
Quote:
Originally Posted by Fred Kiehl View Post
That pin is the outer shaft that fits in the frame, and runs against the frame as a bearing to control the pinion gear against the sector gear. It should not move.
By the way I did confirm through experiment that this pin does not move.
chillrobb is offline  
post #7 of 10 (permalink) Old 09-06-2016, 02:36 PM Thread Starter
Member
 
chillrobb's Avatar
 
Join Date: Feb 2016
Posts: 90
 
Fixed

Alright I fixed the problem. I pulled the motor and regulator assembly out. For some reason this time around it was super easy, maybe because the motor works and I could control the height of the window. I also used duct tape to hold the window in place. Anyways, I used my Dremel to cut and grind down that pin. The pin was also much longer than the other two motors I had. I reinstalled and the window works fine all the way down and all the way up! Took me like 10 minutes and I only broke more plastic on the door panel, which seems unavoidable.
chillrobb is offline  
post #8 of 10 (permalink) Old 09-06-2016, 07:10 PM
Senior Member
 
SEO9C1's Avatar
 
Join Date: Apr 2008
Location: Gettysburg
Posts: 1,843
 
Quote:
Originally Posted by chillrobb View Post
Alright I fixed the problem. I pulled the motor and regulator assembly out. For some reason this time around it was super easy, maybe because the motor works and I could control the height of the window. I also used duct tape to hold the window in place. Anyways, I used my Dremel to cut and grind down that pin. The pin was also much longer than the other two motors I had. I reinstalled and the window works fine all the way down and all the way up! Took me like 10 minutes and I only broke more plastic on the door panel, which seems unavoidable.
Yes. that pin has to be ground down to prevent unwanted contact/obstruction.

Post 2, Instruction 10, Picture 20
SEO9C1 is offline  
post #9 of 10 (permalink) Old 09-07-2016, 11:30 AM Thread Starter
Member
 
chillrobb's Avatar
 
Join Date: Feb 2016
Posts: 90
 
Quote:
Originally Posted by SEO9C1 View Post
Yes. that pin has to be ground down to prevent unwanted contact/obstruction.

Post 2, Instruction 10, Picture 20
Nice post, but I didn't do anything with that index mark. My window works great, but I definitely didn't pay any attention to an index mark. When I cut off the rivets holding the motor to the regulator, the spring fell out. I put the spring back in place comparing it to pictures I found and there were some marks on the bracket and spring that indicated how the spring was oriented. Now the second time I removed the assembly, the spring was held in place, it had tension from the new motor. But, there was absolutely no tension when I put the spring in with the motor removed. I still don't know if I put it in right, but since it works I assume I did it correctly. But I can also imagine that somehow I did it wrong and the spring gets tension by rolling the window up; which would have the opposite intended effect. I really don't feel like messing with it anymore, but now I am concerned.
chillrobb is offline  
post #10 of 10 (permalink) Old 09-27-2016, 12:07 AM
Senior Member
 
SuperSport's Avatar
 
Join Date: Mar 2010
Location: Baton Rouge, LA Area
Posts: 796
 
Wish I came across this last weekend. Sadly, did a quick search, but guess not hard enough. Have the same concern with that "pin" being slightly longer on the replacement part. My assembly "catches" slightly, but doesn't get hung up.


Sent from my iPhone using Tapatalk

-SuperSport- ISSCA #2476
'95 Impala SS (#1,245 of 18,365) --- It's alive, but not quite complete... SLOW PROCESS!

SuperSport is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome