cooling fans - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 01-09-2019, 12:21 PM Thread Starter
Member
 
Join Date: Jul 2010
Posts: 63
 
cooling fans

are both fan supposed to turn on at the same time ? any way to test fans on my 96 impala ss only passenger fan goes on
96ssbwtie is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 01-09-2019, 12:31 PM
Senior Member
 
Join Date: Jan 2001
Location: St. Louis
Posts: 7,705
 
Under normal operating conditions the answers are, "No" and "Yes", in that order.

\'96SS SOB: SSRI, Herter Tune, Tri-Y II, , 3000 Edge, F/HO bars, METCO extendeds with CV MMC, Bilsteins, currently Vredestein Ultrac Sessanta (315/35 rear). Finally, wait for it... LT-4 knock module!
\'96FWB BUW-Butt Ugly White: PCMPerformance tune, HDFA w/ swissed filter, 1/2 SLP s.s. catback with H- and Flow Super 50s, oem opti rebuilt 3 times, SS Bars, METCO LCA, Airlift 1000, Monroe SS, PowerTrax No-Slip, CTS wheels with +1 rubber. Finally, yes again... LT-4 knock module!
96 Black is offline  
post #3 of 5 (permalink) Old 01-09-2019, 12:47 PM Thread Starter
Member
 
Join Date: Jul 2010
Posts: 63
 
so when do both fans go on how can i test them any advise i would appreciate it thanks
96ssbwtie is offline  
 
post #4 of 5 (permalink) Old 01-09-2019, 12:50 PM
Senior Member
 
4DoorSS's Avatar
 
Join Date: Nov 2008
Location: Beautiful Chester County, PA
Posts: 7,974
 
Quote:
Originally Posted by 96ssbwtie View Post
are both fan supposed to turn on at the same time ? any way to test fans on my 96 impala ss only passenger fan goes on
Gary sells some nice products for our cars but ALSO on his Website is a process for how to test the fans....

Caprice / Impala SS / Roadmaster | Innovative Wiring

And here is that Text if the link doesnt work...

FAN TESTING
If you are having cooling fan problems here are few steps to help you fix them.

1) Check the two 40 amp fan fuses.

2)Pull the two fan relays and look at the fuse box is the plastic around the terminals melted? If so you will probably need a TSB Fan harness if everything looks good reinstall relays.

3)Start the car and pull the connector off the temp sender located in the water pump and both cooling fans should come on. (give it a few seconds). If both fans come on then the system is working correctly.

4)If no fans come on check the ground wires for the fan mounted on the core support on the passenger side.

5)If only one fan comes on swap the fan relays and see if the running fan also swapped if so you have a bad fan relay.

6)If you still have the same fan not working check the fan motor by unpluging the connector on the fan and jump the motor with wires one wire to ground and one wire to 12 volts the fan should spin if not fan motor is bad.

================================================== =============


'95 Caprice SS conversion - Bonny Buckets - 96 Column, Shifter and Console - 3.73 Gear and Herter tune - Z/28 Cluster - Blazer OH Console - Green/Pink bushings - Chromed Impala Wheels - Eibach Springs and Bilstein Shocks - Corvette Engine Dress - the list goes on and still more to do...it never ends.
4DoorSS is offline  
post #5 of 5 (permalink) Old 01-09-2019, 01:02 PM Thread Starter
Member
 
Join Date: Jul 2010
Posts: 63
 
thanks bud
96ssbwtie is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome