No Blow From AC/Heat - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 01-14-2019, 05:58 PM Thread Starter
Senior Member
 
WaWaZat's Avatar
 
Join Date: Apr 2007
Location: Chicago
Posts: 566
 
No Blow From AC/Heat

My climate control in my ‘95 wagon lights up.... fan speed lights even operate.... but nothing is blowing. Short on time so brought it to my local mechanic. They tell me it’s the blower motor and blower motor resistor. This is my 300k mile winter car, but may be getting rid of it in a year or so, so don’t want to rack up a bill. They tell me the motor is $55 and resistor $200.... plus $100 install.

Any recommendations on where to at least save money on the resistor and pick one up for much less?

Michael Szromba
'95 Roadmaster Wagon almost 300K miles
'94 Roadmaster Wagon low 100K miles
...both burgundy woodgrain!
WaWaZat is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 01-14-2019, 06:15 PM
Senior Member
 
jayoldschool's Avatar
 
Join Date: Jan 2001
Location: the Great White North
Posts: 5,704
 
Buy a used resistor from one of us. Bench test your fan, replace with used if needed. Replace them yourself. It will take about 20 min.

Old cars, just like classic rock... 60s, 70s, 80s, and 90s!
jayoldschool is offline  
post #3 of 4 (permalink) Old 01-14-2019, 06:46 PM
Senior Member
 
Join Date: Jan 2001
Location: St. Louis
Posts: 7,705
 
Your symptoms do not sound exactly like I had, but enough same components at play that you might pick pieces/hints from here:
https://www.impalassforum.com/vBulle...wer-stays.html

If you have true climate control then it's called a module. A used one is a viable gambit, but did not pan out for me. I found cheaper equally performing alternates to "that genuine GM feeling".


EDIT: As referred below, parts procured on this forum are historically more reliable than internet, though I (luckily) got extra-rapid refund for my (unfortunately dead) ebay purchase.

\'96SS SOB: SSRI, Herter Tune, Tri-Y II, , 3000 Edge, F/HO bars, METCO extendeds with CV MMC, Bilsteins, currently Vredestein Ultrac Sessanta (315/35 rear). Finally, wait for it... LT-4 knock module!
\'96FWB BUW-Butt Ugly White: PCMPerformance tune, HDFA w/ swissed filter, 1/2 SLP s.s. catback with H- and Flow Super 50s, oem opti rebuilt 3 times, SS Bars, METCO LCA, Airlift 1000, Monroe SS, PowerTrax No-Slip, CTS wheels with +1 rubber. Finally, yes again... LT-4 knock module!

Last edited by 96 Black; 01-14-2019 at 09:33 PM. Reason: possesive case v. contraction don't cha no- Plus editorial on forum sellers
96 Black is offline  
 
post #4 of 4 (permalink) Old 01-14-2019, 07:18 PM
Senior Member
 
Fred Kiehl's Avatar
 
Join Date: Feb 2009
Location: Largo, FL 33774
Posts: 10,868
 
Check the fan by removing it, and putting battery voltage across the leads (it has a lot of torque, so be careful), and if the fan works, replace the module (you can get one here for about $50). If the fan does not run, replace the fan (also available here for about $50). I have both parts.

1991 OCC 461 (.030 over 454) BBC, 3.23 posi, flash to pass, drop spindles & springs, Impala rims, Hydroboost, Recaros, MOMO/wood SW w/QR, custom wood shift knob, Pioneer DEH P77DH
1992 OCC now with 5.7 tbi, DEH P77DH
For a parts list, check https://www.impalassforum.com/vBulle...ion-parts.html
Fred Kiehl is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome