Odd power issue to head unit. 9C1 related. - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 11-29-2006, 12:45 PM
DemonNeno
Guest
 
Posts: n/a
Post

I purchased a Metra harness kit from Best Buy and found myself with a huge problem! My 9C1 has the interior light kill button beside the radio, which shuts off the digital display and the lights from the head unit.

Enough background, now to the problem! With the OE AM/FM radio, the switch kills the lights to BOTH the radio and the display. With the NEW head unit installed, with the the interior lights switched on (get a display) it kills my head unit's power! So when I kill the headunit, the dash works. When i kill the dash, the headunit turns on.. uhmmm.. HOW?! Please LMK asap if you have any ideas or know which wire would be responsable for this..? TIA!!
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome