Have amp, also have question - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 08-03-2002, 01:14 PM
CapalaSS
Guest
 
Posts: n/a
Post

Ok, I have a Rockford Fosgate Punch 200watt 4-channel amp. I had two punch z 200watt 4ohm subs hooked to it but I kept blowing them. Im not sure if they were wired wrong or if my enclosure was too small (home built with mdf but not to specs). So what I'm wondering is are those speakers able to handle the power of my amp? Should I go bigger? Also if someone would explain the best way to wire 2 single voice coil subs to a 4-channel amp, it would be greatly appreciated. And what would everyone recommend size for my power cable, I'm running 10awg but I'm not sure if thats large enought.

Thank you,
CapalaSS
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 08-03-2002, 07:42 PM
kilr95ss
Guest
 
Posts: n/a
Post

I dont think you are over powering them, unless they are 100 watts rms and 200 peak. I have 2 XLC 15's with a Punch 250a2 on each. One amp puts out 392 watts, the other 403. It took about 30 minutes before I fried one of them.

I'm not sure how the channels are on the 4 channel amps, but you should be able to mono each pair of channels to get a 4ohm mono output on each.

If your are bridging both woofers off one set of channel and you have 2 4ohm woofers, you have put the amp into 2omh momo, the amp isnt stable at that load, it doubles the watts but overheats the amp.

Hope this helps.

PS. My system hit 142spl with the windows up.
post #3 of 4 (permalink) Old 08-04-2002, 09:03 PM
CapalaSS
Guest
 
Posts: n/a
Post

Yea they were 100watt RMS and 200watt max. And my gains were usually up most of the way. I had them wired like... + from channel 1 to + on sub, - from channel two to same sub -. Then the same for the other sub on channels 3 and 4. Im pretty sure the subs weren't able to handle that power, as RF usually under rates their amps. I also have another question. How many sets of RCA's should I hook up? I have outputs on my CD player for front and rear and my amp has inputs for front, rear, and pass-thru. Sorry for all the questions, I'm about to buy new subs and I want to get everything right this time.

Thanks,
CapalaSS
 
post #4 of 4 (permalink) Old 08-05-2002, 06:22 PM
kilr95ss
Guest
 
Posts: n/a
Post

To get your fad function working, you need to hook up both sets of outputs to the amp, or preferably a electronic crossover. The built in x-overs in the Fosgate amps are very good, but with a external x-over you can dial in your frequencies alot better.
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome