6x9's turned staticy - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 07-16-2003, 01:18 AM
Formula14
Guest
 
Posts: n/a
Post

Ok i've had boston 6x9's in my car for a while and ive noticed that they have both started to get distorted at a much lower volume than usual. I have had to unplug the left one because it is so annoying. Are they blown? I got my rear window smashed a few weeks ago and some glass fragments got in them, and i stupidly left the glass in a few days before cleaning them out. Could the glass have screwed them up? I have a four channel amp sitting in my room, i might hook that up to them to make sure its not my radio thats doing it. Thanks guys
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 07-16-2003, 09:34 AM
mrthump77
Guest
 
Posts: n/a
Post

Mine did the same. I had a heck of a time finding why. It turns out that I had a bad Fosgate Rca underneath the carpet. I had to remove and replace it and it was good as new. I'm sure your case can be numerous things though.
post #3 of 8 (permalink) Old 07-16-2003, 10:36 AM
Formula14
Guest
 
Posts: n/a
Post

I also noticed the problem more when i flipped my subs around in the trunk, i used to have them pointing forward but than flipped them around so they would be a little louder. I dont know if that could have any effect on them.
 
post #4 of 8 (permalink) Old 07-16-2003, 10:58 AM
ghoSStripe
Guest
 
Posts: n/a
Post

Your left is worse than your right? I would swap the speaker wires that go to the speakers and see if the right becomes worse than the left. If nothing changes then the problem is with your speaker. If the right is worse then you know you have a problem with something else like thump said. I would then swap the rcas from left to right. If no change then your amp is to blame. I think that this is a speaker problem though. Have you taken them out and looked at them?
post #5 of 8 (permalink) Old 07-16-2003, 01:29 PM
Formula14
Guest
 
Posts: n/a
Post

The speakers were hooked up to my receiver, The right one has now gotten just as bad as the left one, I hooked up an old amp and they distorted just like they were earlier, i guess it is a speaker problem, they still handle the highs fine but at low and mid frequencies they distort. I have had them out and they look normal to me, They are Boston acoustics FX93, I need to find a good replacement for them, any suggestions. I want to spend around $100. I think i may also hook up my 4 ch amp to all my interior speakers, 75 watts Rms is about right for them isn't it?

Thanks
post #6 of 8 (permalink) Old 07-16-2003, 01:32 PM
Formula14
Guest
 
Posts: n/a
Post

The thing that really peeves me is that i had them less than 2 years and i never ever pushed them even close to their limit. This sucks.
post #7 of 8 (permalink) Old 07-16-2003, 09:07 PM
jboy
Guest
 
Posts: n/a
Post

If they are the style thast have the tweeter mounted on a pedistal thru the center of the 6x9 then glass shards may have made their way down between the pedistal and voice coil, that would realy mess em up.
post #8 of 8 (permalink) Old 07-17-2003, 06:24 PM
Formula14
Guest
 
Posts: n/a
Post

Yup the tweeter is on a pedastal in the middle, I guess it is not a coincidence that the static started right after the window was smashed Thanks for the help
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome