What Can go wrong? - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 02-05-2007, 03:45 PM
ssmoky_lt1
Guest
 
Posts: n/a
Post

Im running my Rockford bd20001 with my 2 sony xplod 12's...yea its funny..hahaha...For now..im still waiting on my set of mtx 9500..i been using the amp with just 4 gauge wire and 250amp fuse soon to upgrade to 0Gauge wires...and just the optima red top battery...im going with a rockford fosgate 25 farad capasitor...but im not yet ready 2 buy...what can go wrong if im going to run that system setup from just the battery no capasitor?i always turn it up loud when the car is on...i never pound it off..Other that dimming headlights and break lights..lol...
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 02-05-2007, 03:53 PM
cuba069
Guest
 
Posts: n/a
Post

im going with a rockford fosgate 25 farad capasitor...but im not yet ready 2 buy...what can go wrong if im going to run that system setup from just the battery no capasitor?

well you damn car might not start if ever system is running without car on....forget the capcitor it helps but not that much...i got a yellow top upgraded my alternator 140 amps(L99 stock is 105)
with a 10 farad capacitor i finally got it not to dim.now what i suggest and iam sure others will, put another red top in the back and you will be fine plus you might be givin a constint 14.5 volts which will make that rockford really BTW get those POS speakers out your car
post #3 of 8 (permalink) Old 02-05-2007, 04:16 PM
ssmoky_lt1
Guest
 
Posts: n/a
Post

Quote:
Originally posted by grey95L99:
im going with a rockford fosgate 25 farad capasitor...but im not yet ready 2 buy...what can go wrong if im going to run that system setup from just the battery no capasitor?

well you damn car might not start if ever system is running without car on....forget the capcitor it helps but not that much...i got a yellow top upgraded my alternator 140 amps(L99 stock is 105)
with a 10 farad capacitor i finally got it not to dim.now what i suggest and iam sure others will, put another red top in the back and you will be fine plus you might be givin a constint 14.5 volts which will make that rockford really BTW get those POS speakers out your car
U be supprised those POS Sonys actually hit..hahaha...Im not kidding 4 reals...I thought they are a POS Till i connected them...they look like they gonna blow too..haha...i wired both down to 2ohms and its a little over 1200rms to both and itz taking one hell of a beating!hahaha...But 14.4 volts for sure will make that amp happy...i got a 140amp altornator too...Im gonna post up a video of those 12's running...hahaha
 
post #4 of 8 (permalink) Old 02-05-2007, 04:40 PM
cuba069
Guest
 
Posts: n/a
Post

na you dont have to post a vid...i know all about theme [img]graemlins/.gif[/img] na really a buddie of mine had 6 of theme in a box chevy i guess they hit... warming that baby up till you get some reall speakers huh....****t good luck man if you got any questions or concerns pm me i will try to help take it easy ...BTW you should put the bass knob all the way to the right,maybe turn up the gain just a little see how long they hold up for....be easy man.
post #5 of 8 (permalink) Old 02-07-2007, 03:27 PM
ssmoky_lt1
Guest
 
Posts: n/a
Post

Quote:
Originally posted by grey95L99:
na you dont have to post a vid...i know all about theme [img]graemlins/.gif[/img] na really a buddie of mine had 6 of theme in a box chevy i guess they hit... warming that baby up till you get some reall speakers huh....****t good luck man if you got any questions or concerns pm me i will try to help take it easy ...BTW you should put the bass knob all the way to the right,maybe turn up the gain just a little see how long they hold up for....be easy man.
2day i blew one of my sony xplods!hahaha...i waz driving and smoke came out the trunk...i had the gain on 1/4 and bASS knob in the center...hahaha...itz crazy!...u ** right...i can't wait till my mtx comez...the sony speaker is crispy...u cant even push the speaker in...hahahaha...it waz fun tho!hahaha
post #6 of 8 (permalink) Old 02-08-2007, 09:33 AM
cuba069
Guest
 
Posts: n/a
Post

ssmoky_lt1 your name got a whole different meaning now...lol..yea it wasent long till they went...i know your hurting now..from havin bass(well some kind of bass [img]tongue.gif[/img] )to nothin sucks but you will be beatin down the block in no time.
post #7 of 8 (permalink) Old 02-08-2007, 01:37 PM
ssmoky_lt1
Guest
 
Posts: n/a
Post

thatz tha name...SSmoky!lolz...yea imma have no bass for like a week till my mtx 9500 comez in...
post #8 of 8 (permalink) Old 02-08-2007, 01:57 PM
elvistass
Guest
 
Posts: n/a
Post

Just to let you know if the bass nob was 1/2 way up then amp was actually 1/2 way, because the bass knob overides the gain setting on the amp.....
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome