ATTN Car Audio Experts.... - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 09-10-2003, 08:43 PM
Not a Cop
Guest
 
Posts: n/a
Post

I have been trying to find out how to get a sub back in my car without adding 50+ lbs. I believe the solution is going to come in the form of an "Aperiodic Membrane" setup, basically I would mount the sub free air in the rear deck of the car, then attach this aperiodic membrane to the front of the sub, it restricts the movement of the sub.


Everything I have read says that this leads to very musical bass but not tons of output. I have a higher power amp (not real clean but high power and it will work for now) and I have a sub I could use for now, but it is pretty heavy, I also intend to find a real lightweight sub to use. Any suggestion on a good 10 or 12" sub that would weight 15 lbs or less. I think I remember an advent sub that had the magnet mounted inside the speaker cone that used a Neodymium (don't think I spelled that right) magnet, that is much more efficient. if I remember right the 12" version of that was only like 8 lbs, anybody know what I am trying to think of?


Anyway if anyone has any experience with this or even knows what I am talking about let me know.


I have heard they are very expensive to have done and I am poor, so as a last resort I could have someplace local like Benchmark Auto Sound and Security here in Springfield, IL do it (they were rated #1 install team nationally last year, but there prices are a bit steep). But I would rather try it myself if at all possible.


Thanks in advance.
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 09-10-2003, 09:49 PM
chevmdnss
Guest
 
Posts: n/a
Post

Impala SS w/Membrane

contact Steve Cornell. Very nice guy. Very helpful. Has done what you are talking about, and can probably help you out.

He is on the board too.
Steve Cornell
Senior Member
Member # 674
post #3 of 7 (permalink) Old 09-11-2003, 05:37 AM
bbodyguy
Guest
 
Posts: n/a
Post

How about a pair of pioneer 10's and hacks board? Fairly light, great musical bass, and cheap! What amp is it? If it is not "clean", it either is weak or not in good health. Just about any amp made today is clean, but may be over rated in power. In either case, make sure you have a strong enough amp. Clipped output will heat up voice coils.

Peter
 
post #4 of 7 (permalink) Old 09-11-2003, 07:32 AM
Not a Cop
Guest
 
Posts: n/a
Post

It is a sony xplod amp, rated to like 760 watts, model 2150 or something like that.


It is also rated at like 1 ohm stable, but if you try and run it at anything other than 4 ohm stereo, or 4 ohm bridged it will blow fuses or go into protect mode. It is kinda crappy but I got it for free.

The sub I have is a RF HE2 DVC, decent sub, kinda heavy, but I got it for $75 with 2 different pre-fabbed boxes a sealed and a ported. So I can't really complain there either.


I would love to get a nice MTX amp for my subs then like a big PPI or Xtant, or soundstream for my highs, but as I said earlier money is tight right now, and I have lots of other things to spend my cash on first.


I have seen that baffle board, but want to do something different and try something that not many people have done before.


The things I have read about the Aperiodic Membrane setups is that they are more musical than even a free air setup but do not have as much output, which I am not real conscerned about.
post #5 of 7 (permalink) Old 09-12-2003, 09:59 AM
PEZOHOLIC
Guest
 
Posts: n/a
Post

I think and the general concensus on Sony Xplod sh!t is that IT SUCKS.

Sony makes damn good TVs, Home funishings and other things but there CAR AUDIO is horrid I think.

Sell the amp and get a decent Xtant, MTX, Rockford, PPI, Zapco, MMATS, PG, ect...

You really do pay for what you get with audio thats why I decided to go with brand names and more expesive stuff, and I even have a setup that needs inprovement. I want to get another sub and go with those new pioneer components but hey I want PERFORMANCE right now not louder subs.
post #6 of 7 (permalink) Old 09-12-2003, 01:51 PM
Not a Cop
Guest
 
Posts: n/a
Post

Quote:
Originally posted by Not a Cop:
It is a sony xplod amp, rated to like 760 watts, model 2150 or something like that....It is kinda crappy but I got it for free.
It works and it was free, I am more conscerned with the sub setup right now, and when I have some spare cash burning a hole in my pocket I will get a new amp. But for my purposes it works fine right now.
post #7 of 7 (permalink) Old 09-15-2003, 11:34 PM
buffman
Guest
 
Posts: n/a
Post

Id have to agree. sony makes excellent home products like tvs, but their car stuff isnt anything close to special. I did a friends stereo about a year ago. Same 760 watt amp, and 2 12 inch sony xploid subs that he got from a friend of his. they were still in the box, only had been used once to see how they sounded. Amp was brand new. Well got everything done, and it sounded great for about 2 months. Subs went out. Turns out the voice coils went bad. Not to long after that the amp finally gave out on him and was unable to return it for a refund.. I would rather have jensen stuff then sony.

Matt
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome