FS Fuel Pumps! - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 09-25-2010, 06:35 PM Thread Starter
Senior Member
 
Join Date: Nov 2004
Location: Cherry Point, NC
Posts: 340
 
Garage
FS Fuel Pumps!

Nearing one month ago I had what "I thought" was a fuel pump problem. Had power all the way to the tank, could not hear the pump, must be the pump. I decided to shop on the Forum and purchased two fuel pumps, just in case. Purchased a new Walbro 255 for $80.00 shipped to me and $30.00 for a 7K mile stock pump. Of course tank was nearly full!

Removed tank installed Walbro 255 then reinstalled tank, still no go, what to hell? Out comes the tank again and this time I decide I should also check the sending unit wiring. There was the problem.

Called a friend of mine who just happened to have a new sending unit on the shelf, only problem was the sending unit was complete with yet anothe pump. For $180.00 I took the unit and installed, all OK. I had Chevrolet check the old sending unit and pump. Pump was great, sending unit junk.


Sooooo,,, if anyone needs a fuel pump I have two on the shelf and would sell them shipped to you for what I paid...

Have a great day.

Larry
Deputy347K9 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome